Announcing Ext JS Upgrade Adviser GA

Ext JS Upgrade Adviser 1.0 Release

We are excited to announce the release of Ext JS Upgrade Adviser 1.0. Ext JS Upgrade Adviser scans your Ext JS 4.x and 5.x applications and reports problems in the source code that need to be addressed before upgrading to a later Ext JS version (6.x). Ext JS Upgrade Adviser includes:

  • Ext JS ESLint Plugin that can be run on an Ext JS application from the command line or integrated with an IDE such as Visual Studio Code
  • Ext JS ESLint Plugin provides ESlint rules that will help you identify the use of removed, private and deprecated classes, methods, configs and properties​ and the overriding of existing aliases, classes and methods
  • Ext JS ESLint Plugin provides the options to auto fix certain identified problems
  • A desktop application is provided to visually see the results of the scan as well as the affected source code
  • Support for both Classic and Modern

Benefits of Upgrading to Ext JS 6.x

Ext JS 6.x supports universal applications targeting desktops, tablets, and smartphones, using a single codebase. We introduced a number of new components in Ext JS 6.x – Pivot Grid, Calendar, D3, enhanced exporter. In addition to these new components, we have made grid enhancements including row body widgets, accessibility improvements with ARIA functionality in the core and new Graphite accessible theme. Ext JS npm packages, ExtGen and ExtBuild are available with Ext JS 6.x/

Try Ext JS Upgrade Adviser


Written by Jones EST

SHARE THIS POST

COMMENTS

Start the Discussion!

Your email address will not be published. Required fields are marked *